Issues with Connect

Incident Report for Extensis

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:40 PDT

Monitoring

AWS US-East-1 is experiencing a major outage impacting our services. We’re actively monitoring status updates from our cloud provider and will share new information as soon as it becomes available.
Posted Oct 20, 2025 - 12:10 PDT
This incident affected: Extensis Connect (Connect Fonts, Administration).